PHP  
 PHP_5_4
downloads | QA | documentation | faq | getting help | mailing lists | reporting bugs | php.net sites | links | my php.net 
 

Skip Report for ext/pdo_mysql/tests/bug_41125.phpt

Script

<?php
require_once(dirname(__FILE__) . DIRECTORY_SEPARATOR 'skipif.inc');
require_once(
dirname(__FILE__) . DIRECTORY_SEPARATOR 'mysql_pdo_test.inc');
MySQLPDOTest::skip();

$db MySQLPDOTest::factory();
$row $db->query('SELECT VERSION() as _version')->fetch(PDO::FETCH_ASSOC);
$matches = array();
if (!
preg_match('/^(\d+)\.(\d+)\.(\d+)/ismU'$row['_version'], $matches))
    die(
sprintf("skip Cannot determine MySQL Server version\n"));

$version $matches[0] * 10000 $matches[1] * 100 $matches[2];
die(
"skip $version");
if (
$version 40100)
    die(
sprintf("skip Need MySQL Server 5.0.0+, found %d.%02d.%02d (%d)\n",
        
$matches[0], $matches[1], $matches[2], $version));
?>

Reason

51501

 

Generated at Tue, 25 Nov 2014 09:11:11 +0000 (15 hours ago)

Copyright © 2005-2014 The PHP Group
All rights reserved.